summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-22 21:31:37 +0200
committerFelix Fietkau <nbd@nbd.name>2016-06-07 08:58:40 +0200
commit9ae952cf8cf2f0d7df95434c8b16d13bc1b47fca (patch)
treebddaea12a78ddd55708a508c02bfb74552bbc7ed /include/kernel.mk
parent1a3c56f8322d27f4652d23eb7dc14a45e1631e1c (diff)
downloadmaster-31e0f0ae-9ae952cf8cf2f0d7df95434c8b16d13bc1b47fca.tar.gz
master-31e0f0ae-9ae952cf8cf2f0d7df95434c8b16d13bc1b47fca.tar.bz2
master-31e0f0ae-9ae952cf8cf2f0d7df95434c8b16d13bc1b47fca.zip
build: split scripts/metadata.pl into target-metadata.pl and package-metadata.pl
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 2b87aeba33..8ce4df8f2d 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -215,7 +215,7 @@ $(call KernelPackage/$(1)/config)
$$(IPKG_kmod-$(1)): $$(wildcard $$(FILES))
endef
-version_filter=$(if $(findstring @,$(1)),$(shell $(SCRIPT_DIR)/metadata.pl version_filter $(KERNEL_PATCHVER) $(1)),$(1))
+version_filter=$(if $(findstring @,$(1)),$(shell $(SCRIPT_DIR)/package-metadata.pl version_filter $(KERNEL_PATCHVER) $(1)),$(1))
define AutoLoad
add_module "$(1)" "$(call version_filter,$(2))" "$(3)";