summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-10-18 06:58:11 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-10-18 06:58:11 +0000
commit8a6ee777b029d89d6dbd89ea786d699072731c2f (patch)
treed3f40a7f805a02bf233b07e7c1d7435d0abc7bdb /include/kernel.mk
parentaf0e5167bc200a82421a5f8b33c332fbdf21da0e (diff)
downloadmaster-31e0f0ae-8a6ee777b029d89d6dbd89ea786d699072731c2f.tar.gz
master-31e0f0ae-8a6ee777b029d89d6dbd89ea786d699072731c2f.tar.bz2
master-31e0f0ae-8a6ee777b029d89d6dbd89ea786d699072731c2f.zip
make ModuleAutoLoad more readable
When doing a build with tracing on, the expansion of ModuleAutoLoad can get a little hairy. Using intermediate variables to name the arguments makes tracing more readable. One side effect is that if an argument is accidentally left out, we won't get all of the parameters shifted one over thanks to quoting (done in AutoLoad). Signed-of-by: Philip Prindeville <philipp@redfish-solutions.com> SVN-Revision: 23513
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk16
1 files changed, 10 insertions, 6 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 6ef4fd942d..6795bd49fc 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -67,16 +67,20 @@ define ModuleAutoLoad
$(SH_FUNC) \
export modules=; \
add_module() { \
+ priority="$$$$$$$$1"; \
+ mods="$$$$$$$$2"; \
+ boot="$$$$$$$$3"; \
+ shift 3; \
mkdir -p $(2)/etc/modules.d; \
( \
- [ "$$$$$$$$3" = "1" ] && { \
+ [ "$$$$$$$$boot" = "1" ] && { \
echo '# May be required for rootfs' ; \
} ; \
- for mod in $$$$$$$$2; do \
- getvar mod; \
+ for mod in $$$$$$$$mods; do \
+ echo "$$$$$$$$mod"; \
done \
- ) > $(2)/etc/modules.d/$$$$$$$$1-$(1); \
- modules="$$$$$$$${modules:+$$$$$$$$modules }$$$$$$$$1-$(1)"; \
+ ) > $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
+ modules="$$$$$$$${modules:+$$$$$$$$modules }$$$$$$$$priority-$(1)"; \
}; \
$(3) \
if [ -n "$$$$$$$$modules" ]; then \
@@ -156,7 +160,7 @@ $(call KernelPackage/$(1)/config)
endef
define AutoLoad
- add_module $(1) "$(2)" $(3);
+ add_module "$(1)" "$(2)" "$(3)";
endef
ifdef DUMP