summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-02-21 11:45:16 +0000
committerJonas Gorski <jogo@openwrt.org>2013-02-21 11:45:16 +0000
commit88ff7e3f23c3aa406dae1d44a3ea731d279f02da (patch)
treec0af8453ff5093326f6e307ce8a1f490d03f492f /include/kernel.mk
parent29a3af1bb8ffc3339ab430ea0d8546e7695e790d (diff)
downloadmaster-31e0f0ae-88ff7e3f23c3aa406dae1d44a3ea731d279f02da.tar.gz
master-31e0f0ae-88ff7e3f23c3aa406dae1d44a3ea731d279f02da.tar.bz2
master-31e0f0ae-88ff7e3f23c3aa406dae1d44a3ea731d279f02da.zip
include/kernel.mk: print warnings/errors to stderr
Makes warnings/errors visible when building with V=w/V=1. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 35713
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 8df70ba5f6..b637de5918 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -163,11 +163,11 @@ $(call KernelPackage/$(1)/config)
if grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \
echo "NOTICE: module '$$$$$$$$mod' is built-in."; \
else \
- echo "ERROR: module '$$$$$$$$mod' is missing."; \
+ echo "ERROR: module '$$$$$$$$mod' is missing." >&2; \
exit 1; \
fi; \
else \
- echo "WARNING: module '$$$$$$$$mod' missing and modules.builtin not available, assuming built-in."; \
+ echo "WARNING: module '$$$$$$$$mod' missing and modules.builtin not available, assuming built-in." >&2; \
fi; \
done;
$(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
@@ -178,7 +178,7 @@ $(call KernelPackage/$(1)/config)
else
compile: kmod-$(1)-unavailable
kmod-$(1)-unavailable:
- @echo "WARNING: kmod-$(1) is not available in the kernel config"
+ @echo "WARNING: kmod-$(1) is not available in the kernel config" >&2
)
endif
$$(eval $$(call BuildPackage,kmod-$(1)))