summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-11-08 14:00:36 +0000
committerNicolas Thill <nico@openwrt.org>2011-11-08 14:00:36 +0000
commit7de2766a02a93360a52626d2e477a9ba2ad40875 (patch)
tree7f361b1aff74507517a8c7c0b205259ed4b870df /include/kernel.mk
parent9906717bfbfbd976f6efbd9152d0edd2cb606611 (diff)
downloadmaster-31e0f0ae-7de2766a02a93360a52626d2e477a9ba2ad40875.tar.gz
master-31e0f0ae-7de2766a02a93360a52626d2e477a9ba2ad40875.tar.bz2
master-31e0f0ae-7de2766a02a93360a52626d2e477a9ba2ad40875.zip
include/kernel.mk: enhance built-in/missing modules detection when packaging kmods
SVN-Revision: 28856
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 0df0337c49..1591c36135 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -157,8 +157,11 @@ $(call KernelPackage/$(1)/config)
if [ -e $$$$$$$$mod ]; then \
mkdir -p $$(1)/$(MODULES_SUBDIR) ; \
$(CP) -L $$$$$$$$mod $$(1)/$(MODULES_SUBDIR)/ ; \
+ elif grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \
+ echo "NOTICE: module '$$$$$$$$mod' is built-in."; \
else \
- echo "WARNING: module '$$$$$$$$mod' does not exist, is it built-in?" ; \
+ echo "ERROR: module '$$$$$$$$mod' is missing."; \
+ exit 1; \
fi; \
done;
$(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))