summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-07-18 15:41:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-07-18 15:41:09 +0000
commit6a559ff95e72c9b53cb32dfedf59c5a256e62d5c (patch)
tree69cfdd31267e0ccb0bd4f994d6a4b5f56d532bae /include/kernel.mk
parenta5f93fad9d8f76deedf6eb0ffb62d574ebe68b59 (diff)
downloadmaster-31e0f0ae-6a559ff95e72c9b53cb32dfedf59c5a256e62d5c.tar.gz
master-31e0f0ae-6a559ff95e72c9b53cb32dfedf59c5a256e62d5c.tar.bz2
master-31e0f0ae-6a559ff95e72c9b53cb32dfedf59c5a256e62d5c.zip
include: modify kernel.mk to build empty kmod packages if the referenced symbols do not exist in the config
SVN-Revision: 37400
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index cbf342a0d2..5442c9153f 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -176,9 +176,13 @@ $(call KernelPackage/$(1)/config)
endif
$(if $(CONFIG_PACKAGE_kmod-$(1)),
else
- compile: kmod-$(1)-unavailable
- kmod-$(1)-unavailable:
- @echo "WARNING: kmod-$(1) is not available in the kernel config" >&2
+ compile: $(1)-disabled
+ $(1)-disabled:
+ @echo "WARNING: kmod-$(1) is not available in the kernel config - generating empty package" >&2
+
+ define Package/kmod-$(1)/install
+ true
+ endef
)
endif
$$(eval $$(call BuildPackage,kmod-$(1)))