summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-22 19:06:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-22 19:06:07 +0000
commit576621f1e353339fe81ece6cff7e8bcd12cbc7b8 (patch)
treed6f0c3870842c1abf95b0cfbf411169d24694f1c /include/kernel.mk
parent3a0266b4716aa12fe1756d7e52a0e5bec760d48d (diff)
downloadmaster-31e0f0ae-576621f1e353339fe81ece6cff7e8bcd12cbc7b8.tar.gz
master-31e0f0ae-576621f1e353339fe81ece6cff7e8bcd12cbc7b8.tar.bz2
master-31e0f0ae-576621f1e353339fe81ece6cff7e8bcd12cbc7b8.zip
linux: add support of Synopsys ARC770-based boards
This patch introduces support of new boards with ARC cores. [1] Synopsys SDP board This is a new-generation development board from Synopsys that consists of base-board and CPU tile-board (which might have a real ASIC or FPGA with CPU image). It sports a lot of DesignWare peripherals like GMAC, USB, SPI, I2C etc and is intended to be used for early development of ARC-based products. [2] nSIM This is a virtual board implemented in Synopsys proprietary software simulator (even though available for free for open source community). This board has only serial port as a peripheral and so it is meant to be used for runtime testing which is especially useful during bring-up of new tools and platforms. What's also important ARC cores are very configurable so there're many variations of options like cache sizes, their line lengths, additional hardware blocks like multipliers, dividers etc. And this board could be used to make sure built software still runs on different HW configurations. Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> SVN-Revision: 47589
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 6a613fe1fd..878a366fc4 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -64,6 +64,8 @@ ifneq (,$(findstring uml,$(BOARD)))
LINUX_KARCH=um
else ifneq (,$(findstring $(ARCH) , aarch64 aarch64_be ))
LINUX_KARCH := arm64
+else ifneq (,$(findstring $(ARCH) , arceb ))
+ LINUX_KARCH := arc
else ifneq (,$(findstring $(ARCH) , armeb ))
LINUX_KARCH := arm
else ifneq (,$(findstring $(ARCH) , mipsel mips64 mips64el ))