summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-22 22:09:40 +0000
committerJohn Crispin <john@openwrt.org>2013-06-22 22:09:40 +0000
commit43a3d87b8370872c5720b4bb6616b797486d38d8 (patch)
tree071d28d9a0101a23619d325007f6309d5ea43479 /include/kernel.mk
parent3df61e827932ae40fd7b1b45c1f8257c145155db (diff)
downloadmaster-31e0f0ae-43a3d87b8370872c5720b4bb6616b797486d38d8.tar.gz
master-31e0f0ae-43a3d87b8370872c5720b4bb6616b797486d38d8.tar.bz2
master-31e0f0ae-43a3d87b8370872c5720b4bb6616b797486d38d8.zip
package: fix insmod on install
the procd changes broke the postinst insmod. Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37015
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index b637de5918..cbf342a0d2 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -105,7 +105,7 @@ define ModuleAutoLoad
echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
echo ". /lib/functions.sh" >> $(2)/CONTROL/postinst; \
- echo "load_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst; \
+ echo "insert_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst; \
chmod 0755 $(2)/CONTROL/postinst; \
fi
endef