summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-10-28 13:10:50 +0000
committerNicolas Thill <nico@openwrt.org>2011-10-28 13:10:50 +0000
commit3bcb16b305726048905f6cc3ab377c5977008a4d (patch)
tree15f9b47f8f8e32e460e18289b1a9ce563cb23c67 /include/kernel.mk
parentb5af64c5294f4bc08fef0e3951ca8d8f5f1ac5d6 (diff)
downloadmaster-31e0f0ae-3bcb16b305726048905f6cc3ab377c5977008a4d.tar.gz
master-31e0f0ae-3bcb16b305726048905f6cc3ab377c5977008a4d.tar.bz2
master-31e0f0ae-3bcb16b305726048905f6cc3ab377c5977008a4d.zip
package/blockmount: simplify extroot module loading logic
SVN-Revision: 28650
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 9e94dce3b9..0df0337c49 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -90,7 +90,8 @@ define ModuleAutoLoad
done; \
if [ -e $(2)/etc/modules.d/$$$$$$$$priority-$(1) ]; then \
if [ "$$$$$$$$boot" = "1" ]; then \
- echo '# May be required for rootfs' >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
+ mkdir -p $(2)/etc/modules-boot.d; \
+ ln -s ../modules.d/$$$$$$$$priority-$(1) $(2)/etc/modules-boot.d/; \
fi; \
modules="$$$$$$$${modules:+$$$$$$$$modules }$$$$$$$$priority-$(1)"; \
fi; \