summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-08-05 14:08:47 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-05 14:17:08 +0200
commit22ef1c83b35cd5633b0c58c9c38a43494a906a6a (patch)
treee790cae0c3ca6ed67e48d184999c3e46ae96d483 /include/kernel.mk
parent51e70267bd7ba886314f87317f31342f8e39f602 (diff)
downloadmaster-31e0f0ae-22ef1c83b35cd5633b0c58c9c38a43494a906a6a.tar.gz
master-31e0f0ae-22ef1c83b35cd5633b0c58c9c38a43494a906a6a.tar.bz2
master-31e0f0ae-22ef1c83b35cd5633b0c58c9c38a43494a906a6a.zip
kernel: make the kernel build auto-clean the build dir like package builds
Previous behavior can be restored by using QUILT=1 on target/prepare Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 8ce4df8f2d..2721c83d8e 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -30,8 +30,8 @@ else
endif
ifeq ($(TARGET_BUILD),1)
- PATCH_DIR ?= ./patches$(if $(wildcard ./patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
- FILES_DIR ?= $(foreach dir,$(wildcard ./files ./files-$(KERNEL_PATCHVER)),"$(dir)")
+ PATCH_DIR ?= $(CURDIR)/patches$(if $(wildcard ./patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
+ FILES_DIR ?= $(foreach dir,$(wildcard $(CURDIR)/files $(CURDIR)/files-$(KERNEL_PATCHVER)),"$(dir)")
endif
KERNEL_BUILD_DIR ?= $(BUILD_DIR)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))
LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)