summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-02 18:12:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-02 18:12:29 +0000
commit120a88b9da6d8d1b7a04d60e1b25b9925d58eb19 (patch)
tree257c7a050b0bd4b31cdf364eadb03587d3342e2f /include/kernel.mk
parent8ca8fd757ab5c55b61bd141f8dba4e21c8ede0c3 (diff)
downloadmaster-31e0f0ae-120a88b9da6d8d1b7a04d60e1b25b9925d58eb19.tar.gz
master-31e0f0ae-120a88b9da6d8d1b7a04d60e1b25b9925d58eb19.tar.bz2
master-31e0f0ae-120a88b9da6d8d1b7a04d60e1b25b9925d58eb19.zip
include/kernel.mk - better search for ARCH
If "findstring" is used without leading and trailing spaces unexpected matches may happen. For example consider ARC=arc then "findstring $(ARCH)" will report a false match with "aarch64". But "findstring $ARCH " (note trailing space) will correctly skip matches for both "aarch64" and "aarch64_be". This patch is built-tested against NetGear WNDR3800. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 47359
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 7a0a170c35..6a613fe1fd 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -62,15 +62,15 @@ endif
ifneq (,$(findstring uml,$(BOARD)))
LINUX_KARCH=um
-else ifneq (,$(findstring $(ARCH), aarch64 aarch64_be))
+else ifneq (,$(findstring $(ARCH) , aarch64 aarch64_be ))
LINUX_KARCH := arm64
-else ifneq (,$(findstring $(ARCH), armeb))
+else ifneq (,$(findstring $(ARCH) , armeb ))
LINUX_KARCH := arm
-else ifneq (,$(findstring $(ARCH), mipsel mips64 mips64el))
+else ifneq (,$(findstring $(ARCH) , mipsel mips64 mips64el ))
LINUX_KARCH := mips
-else ifneq (,$(findstring $(ARCH), sh2 sh3 sh4))
+else ifneq (,$(findstring $(ARCH) , sh2 sh3 sh4 ))
LINUX_KARCH := sh
-else ifneq (,$(findstring $(ARCH), i386 x86_64))
+else ifneq (,$(findstring $(ARCH) , i386 x86_64 ))
LINUX_KARCH := x86
else
LINUX_KARCH := $(ARCH)