summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-01-24 15:36:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-01-24 15:36:05 +0000
commit0333da8943275324d366d562b70f90febbe97e7d (patch)
treed01138f8aa9c91cccbf8e85e4fe0f4bb27d602d4 /include/kernel.mk
parent96afb90f3f96c15cd4bfd6a050538292074cf9da (diff)
downloadmaster-31e0f0ae-0333da8943275324d366d562b70f90febbe97e7d.tar.gz
master-31e0f0ae-0333da8943275324d366d562b70f90febbe97e7d.tar.bz2
master-31e0f0ae-0333da8943275324d366d562b70f90febbe97e7d.zip
include: group kmod ipk files into a "kernel" subdirectory
This is useful to just use the kmods from an official build while supplying base packages from a custom feed or the other way around; for just overriding the kmods with a local repo while using official repos for the rest. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 48475
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 57185c5fd3..3fa9b89c20 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -155,6 +155,7 @@ define KernelPackage
DESCRIPTION:=$(DESCRIPTION)
EXTRA_DEPENDS:=kernel (=$(LINUX_VERSION)-$(LINUX_RELEASE)-$(LINUX_VERMAGIC))
VERSION:=$(LINUX_VERSION)$(if $(PKG_VERSION),+$(PKG_VERSION))-$(if $(PKG_RELEASE),$(PKG_RELEASE),$(LINUX_RELEASE))
+ PACKAGE_SUBDIR:=kernel
$(call KernelPackage/$(1))
$(call KernelPackage/$(1)/$(BOARD))
endef