summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-10 04:21:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-10 04:21:21 +0000
commite83d637f65c15533cdcdbd8ec0c31da6bea48a9b (patch)
treed3830b30620bb04d62c74fa260d5b2b865955efc /include/kernel.mk
parent01b6a90e3dd4ae03ae6702e9c2c4fd94ac4dee83 (diff)
downloadmaster-31e0f0ae-e83d637f65c15533cdcdbd8ec0c31da6bea48a9b.tar.gz
master-31e0f0ae-e83d637f65c15533cdcdbd8ec0c31da6bea48a9b.tar.bz2
master-31e0f0ae-e83d637f65c15533cdcdbd8ec0c31da6bea48a9b.zip
fix kernel build with quilt
SVN-Revision: 8727
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index b2a7476aa0..788e3f2378 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -43,7 +43,9 @@ else
TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING) \
- PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+ ifneq ($(TARGET_BUILD),1)
+ PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+ endif
endif
ifneq (,$(findstring uml,$(BOARD)))