summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-11 23:11:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-11 23:11:02 +0000
commitcf4e7af392186e57f213053a898c62cd9400b692 (patch)
tree1f8a2d1023ef2469dbd0e2040599b3c69807cf92 /include/kernel.mk
parent312802199b7cc09dde5ed867745f4c1baa3c5204 (diff)
downloadmaster-31e0f0ae-cf4e7af392186e57f213053a898c62cd9400b692.tar.gz
master-31e0f0ae-cf4e7af392186e57f213053a898c62cd9400b692.tar.bz2
master-31e0f0ae-cf4e7af392186e57f213053a898c62cd9400b692.zip
make target/linux/* directories self-contained, use the selected kernel version for the toolchain, autogenerate menuconfig and makefile code for target selection
SVN-Revision: 5498
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk30
1 files changed, 11 insertions, 19 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 2611828a3c..09aba40768 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -4,29 +4,14 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
ifeq ($(DUMP),1)
- KERNEL:=<KERNEL>
- BOARD:=<BOARD>
- LINUX_VERSION:=<LINUX_VERSION>
+ KERNEL?=<KERNEL>
+ BOARD?=<BOARD>
+ LINUX_VERSION?=<LINUX_VERSION>
else
-
- include $(TOPDIR)/.kernel.mk
include $(INCLUDE_DIR)/target.mk
- # check to see if .kernel.mk matches target.mk
- ifeq ($(CONFIG_BOARD)-$(CONFIG_KERNEL),$(BOARD)-$(KERNEL))
- LINUX_VERSION:=$(CONFIG_LINUX_VERSION)
- LINUX_RELEASE:=$(CONFIG_LINUX_RELEASE)
- LINUX_KARCH:=$(CONFIG_LINUX_KARCH)
- else
- ifneq ($(KERNEL_BUILD),1)
- # oops, old .kernel.config; rebuild it (hiding the misleading errors this produces)
- $(warning rebuilding .kernel.mk)
- $(TOPDIR)/.kernel.mk: FORCE
- @$(MAKE) -C $(TOPDIR)/target/linux/$(BOARD)-$(KERNEL) $@ &>/dev/null
- endif
- endif
-
ifeq ($(KERNEL),2.6)
LINUX_KMOD_SUFFIX=ko
else
@@ -49,6 +34,13 @@ else
TARGET_MODULES_DIR := $(LINUX_TARGET_DIR)/$(MODULES_SUBDIR)
LINUX_KERNEL:=$(KERNEL_BUILD_DIR)/vmlinux
+
+ LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
+ LINUX_SITE:=http://www.us.kernel.org/pub/linux/kernel/v$(KERNEL) \
+ http://www.us.kernel.org/pub/linux/kernel/v$(KERNEL) \
+ http://www.kernel.org/pub/linux/kernel/v$(KERNEL) \
+ http://www.de.kernel.org/pub/linux/kernel/v$(KERNEL)
+
endif