summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-19 05:01:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-19 05:01:04 +0000
commit87e6a7e4f21ff57ba3ec947614f52967f57a9cbb (patch)
tree8208ce17578f7f973398d68d3332907c4806fe9c /include/kernel.mk
parentedc69c912bb40e98fb96f96c8975a46f3365771f (diff)
downloadmaster-31e0f0ae-87e6a7e4f21ff57ba3ec947614f52967f57a9cbb.tar.gz
master-31e0f0ae-87e6a7e4f21ff57ba3ec947614f52967f57a9cbb.tar.bz2
master-31e0f0ae-87e6a7e4f21ff57ba3ec947614f52967f57a9cbb.zip
cleanup
SVN-Revision: 5224
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index af5d9455fa..42c9cdf3a1 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -18,11 +18,14 @@ else
LINUX_VERSION:=$(CONFIG_LINUX_VERSION)
LINUX_RELEASE:=$(CONFIG_LINUX_RELEASE)
LINUX_KARCH:=$(CONFIG_LINUX_KARCH)
- else
+ else
# oops, old .kernel.config; rebuild it (hiding the misleading errors this produces)
$(warning rebuilding .kernel.mk)
$(TOPDIR)/.kernel.mk: FORCE
- @$(MAKE) -C $(TOPDIR)/target/linux/$(BOARD)-$(KERNEL) $@ &>/dev/null
+ ifneq ($(KERNEL_BUILD),1)
+ $(TOPDIR)/.kernel.mk:
+ @$(MAKE) -C $(TOPDIR)/target/linux/$(BOARD)-$(KERNEL) $@ &>/dev/null
+ endif
endif
ifeq ($(KERNEL),2.6)