summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-03 07:51:56 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-03 07:51:56 +0000
commit6a6fa5a4ab70f9f15f6f87fcf43a1588db612fe2 (patch)
tree3d9b77c4d4bc7c2aa4692bd70568b1f005b2e75d /include/kernel.mk
parentc8862d6777f15214aec4cee6d0f8f59203ebce30 (diff)
downloadmaster-31e0f0ae-6a6fa5a4ab70f9f15f6f87fcf43a1588db612fe2.tar.gz
master-31e0f0ae-6a6fa5a4ab70f9f15f6f87fcf43a1588db612fe2.tar.bz2
master-31e0f0ae-6a6fa5a4ab70f9f15f6f87fcf43a1588db612fe2.zip
provide default PKG_BUILD_DIR for packages missing a PKG_VERSION
SVN-Revision: 8583
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 00d1b8c44c..519ea42d23 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -44,7 +44,7 @@ else
TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING) \
- PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+ PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
endif
GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )