summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-19 06:20:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-19 06:20:55 +0000
commit2665d7f09e8f1b23744fd19243b2747f654e4656 (patch)
tree76e80a9a7acecc3dd2b4c9129323a3311284745f /include/kernel.mk
parentae439d6682f238bcff9c23a88aabc7b3689c0db5 (diff)
downloadmaster-31e0f0ae-2665d7f09e8f1b23744fd19243b2747f654e4656.tar.gz
master-31e0f0ae-2665d7f09e8f1b23744fd19243b2747f654e4656.tar.bz2
master-31e0f0ae-2665d7f09e8f1b23744fd19243b2747f654e4656.zip
cleanup/rewrite of the kernel build process
SVN-Revision: 5226
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 42c9cdf3a1..1ab85d4cc5 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -18,12 +18,11 @@ else
LINUX_VERSION:=$(CONFIG_LINUX_VERSION)
LINUX_RELEASE:=$(CONFIG_LINUX_RELEASE)
LINUX_KARCH:=$(CONFIG_LINUX_KARCH)
- else
- # oops, old .kernel.config; rebuild it (hiding the misleading errors this produces)
- $(warning rebuilding .kernel.mk)
- $(TOPDIR)/.kernel.mk: FORCE
+ else
ifneq ($(KERNEL_BUILD),1)
- $(TOPDIR)/.kernel.mk:
+ # oops, old .kernel.config; rebuild it (hiding the misleading errors this produces)
+ $(warning rebuilding .kernel.mk)
+ $(TOPDIR)/.kernel.mk: FORCE
@$(MAKE) -C $(TOPDIR)/target/linux/$(BOARD)-$(KERNEL) $@ &>/dev/null
endif
endif