summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 23:33:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 23:33:01 +0000
commit0c9b23594d42b9452d44009ad946a0a507823ff6 (patch)
treece1990886fd18efdcf2a3e828453c13fbd8acd97 /include/kernel.mk
parente63e1f7a4a84f305c93e28f073568d0f324e67dd (diff)
downloadmaster-31e0f0ae-0c9b23594d42b9452d44009ad946a0a507823ff6.tar.gz
master-31e0f0ae-0c9b23594d42b9452d44009ad946a0a507823ff6.tar.bz2
master-31e0f0ae-0c9b23594d42b9452d44009ad946a0a507823ff6.zip
fix kmod-crypto, emit warning messages for kmod packages that cannot be built due to missing kernel config options
SVN-Revision: 8697
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index b82668ea48..b2a7476aa0 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -123,6 +123,12 @@ $(call KernelPackage/$(1)/description)
$(call KernelPackage/$(1)/install,$$(1))
endef
endif
+ $(if $(CONFIG_PACKAGE_kmod-$(1)),
+ else
+ compile: kmod-$(1)-unavailable
+ kmod-$(1)-unavailable:
+ @echo "WARNING: kmod-$(1) is not available in the kernel config"
+ )
endif
$$(eval $$(call BuildPackage,kmod-$(1)))