summaryrefslogtreecommitdiffstats
path: root/include/kernel-version.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commita9d683ca912b2c4837b2e65909c09ca01babe3df (patch)
tree6cbca6e13dd0bb18c9d9f1d4baa9a0ea7801b959 /include/kernel-version.mk
parent4a2e4920b1d909ca254853b0dce46af3123e8f74 (diff)
downloadmaster-31e0f0ae-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.gz
master-31e0f0ae-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.bz2
master-31e0f0ae-a9d683ca912b2c4837b2e65909c09ca01babe3df.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
SVN-Revision: 8694
Diffstat (limited to 'include/kernel-version.mk')
-rw-r--r--include/kernel-version.mk14
1 files changed, 6 insertions, 8 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index ee3486fdb1..508cf9934a 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -1,11 +1,9 @@
# Use the default kernel version if the Makefile doesn't override it
-ifeq ($(LINUX_VERSION),)
- ifeq ($(KERNEL),2.4)
- LINUX_VERSION:=2.4.34
- else
- LINUX_VERSION:=2.6.21.5
- endif
+ifeq ($(KERNEL),2.4)
+ LINUX_VERSION?=2.4.34
+else
+ LINUX_VERSION?=2.6.21.5
endif
LINUX_RELEASE?=1
@@ -22,6 +20,6 @@ endif
# disable the md5sum check for unknown kernel versions
LINUX_KERNEL_MD5SUM?=x
-KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
-KERNEL_PATCHVER:=$(shell echo $(LINUX_VERSION) | cut -d. -f1,2,3 | cut -d- -f1)
+KERNEL?=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
+KERNEL_PATCHVER=$(shell echo $(LINUX_VERSION) | cut -d. -f1,2,3 | cut -d- -f1)