summaryrefslogtreecommitdiffstats
path: root/include/kernel-defaults.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:24 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:24 +0000
commiteab95ea46736f8359c5a19a612f0e39160cab80c (patch)
tree81e0c836c0f7eedb3c72df446c113cf344f80aca /include/kernel-defaults.mk
parenta890ccd6e0624e51f6a97f38b6b7d4ee54bb3992 (diff)
downloadmaster-31e0f0ae-eab95ea46736f8359c5a19a612f0e39160cab80c.tar.gz
master-31e0f0ae-eab95ea46736f8359c5a19a612f0e39160cab80c.tar.bz2
master-31e0f0ae-eab95ea46736f8359c5a19a612f0e39160cab80c.zip
buildroot: copy KENRNELNAME files to $(KDIR)
In order to support building both normal and initramfs kernel, we will rebuild the wrappers around the vmlinux ELF binary, copy these with an appropriate extension when they exist. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 37048
Diffstat (limited to 'include/kernel-defaults.mk')
-rw-r--r--include/kernel-defaults.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 9a5eefdf2c..7e807bfaff 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -118,9 +118,19 @@ endef
OBJCOPY_STRIP = -R .reginfo -R .notes -R .note -R .comment -R .mdebug -R .note.gnu.build-id
+# AVR32 uses a non-standard location
+ifeq ($(LINUX_KARCH),avr32)
+IMAGES_DIR:=images
+endif
+
define Kernel/CopyImage
$(KERNEL_CROSS)objcopy -O binary $(OBJCOPY_STRIP) -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)$(1)
$(KERNEL_CROSS)objcopy $(OBJCOPY_STRIP) -S $(LINUX_DIR)/vmlinux $(KERNEL_BUILD_DIR)/vmlinux$(1).elf
+ifneq ($(subst ",,$(KERNELNAME)),)
+ #")
+ $(foreach k,$(subst ",,$(KERNELNAME)),$(CP) $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/$(IMAGES_DIR)/$(k) $(KERNEL_BUILD_DIR)/$(k)$(1);)
+ #")
+endif
endef
define Kernel/CompileImage/Default