summaryrefslogtreecommitdiffstats
path: root/include/kernel-defaults.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-05 16:58:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-05 16:58:16 +0000
commita402b5c48dc505aebc146eec4b2ca179fc18d7fa (patch)
treeb4fe04566be9b7eb1a05cdecdb169d5a0ba78d71 /include/kernel-defaults.mk
parentbf0305725a25a46b6280fc2bf9faa80e121a58b7 (diff)
downloadmaster-31e0f0ae-a402b5c48dc505aebc146eec4b2ca179fc18d7fa.tar.gz
master-31e0f0ae-a402b5c48dc505aebc146eec4b2ca179fc18d7fa.tar.bz2
master-31e0f0ae-a402b5c48dc505aebc146eec4b2ca179fc18d7fa.zip
build: make sure modules are modposted after initramfs image is built
Otherwise the modpost steps for individual modules that are compiled manually (using make package/<name_of_module>/install) will give warning of missing symbols when that module depends other modules. This is caused by the Module.symvers file not containing any symbols anymore of external modules when the initramfs image is built without specifically giving the modules target. Signed-off-by: Tjalling Hattink <t.hattink@fugro.nl> SVN-Revision: 42773
Diffstat (limited to 'include/kernel-defaults.mk')
-rw-r--r--include/kernel-defaults.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index da06abd0a5..523cd5c483 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -150,7 +150,7 @@ endef
define Kernel/CompileImage/Default
rm -f $(TARGET_DIR)/init
- +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME))
+ +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME)) modules
#")
$(call Kernel/CopyImage)
endef
@@ -160,7 +160,7 @@ define Kernel/CompileImage/Initramfs
$(call Kernel/Configure/Initramfs)
$(CP) $(GENERIC_PLATFORM_DIR)/base-files/init $(TARGET_DIR)/init
rm -rf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/usr/initramfs_data.cpio*
- +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME))
+ +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME)) modules
#")
#")
$(call Kernel/CopyImage,-initramfs)