summaryrefslogtreecommitdiffstats
path: root/include/kernel-defaults.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-02 12:45:16 +0000
committerJohn Crispin <john@openwrt.org>2014-06-02 12:45:16 +0000
commit45e3540a3f1189fb36655aeb2347445526d654bd (patch)
tree78c0b180d2003f77c38ffa9dcd60ecb69c485b2a /include/kernel-defaults.mk
parent0de0310a9cbc9a25d01d8823c2fb48974915704c (diff)
downloadmaster-31e0f0ae-45e3540a3f1189fb36655aeb2347445526d654bd.tar.gz
master-31e0f0ae-45e3540a3f1189fb36655aeb2347445526d654bd.tar.bz2
master-31e0f0ae-45e3540a3f1189fb36655aeb2347445526d654bd.zip
config: Remove KERNEL_GIT_LOCAL_REPOSITORY option
The GIT_LOCAL_REPOSITORY option adds the --reference argument to the git clone kernel command line, if KERNEL_GIT_CLONE_URI is set. This option is intended to speed-up the repo creation by using local objets rather than downloading it. However, a local repo can be cloned much faster by setting GIT_LOCAL_REPOSITORY directly to the local tree. In that case, git clone will bypass the normal "git aware" transport mechanism and clone the repository by copying and hardlinking objects rather than downloading it, resulting in a significant speed increase. That makes the GIT_LOCAL_REPOSITORY option pretty useless so we'll just remove it and recommand the usage of KERNEL_GIT_CLONE_URI directly. Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com> SVN-Revision: 40944
Diffstat (limited to 'include/kernel-defaults.mk')
-rw-r--r--include/kernel-defaults.mk10
1 files changed, 2 insertions, 8 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 322aeed5fa..499ecdf3d8 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -40,15 +40,9 @@ ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
touch $(LINUX_DIR)/.quilt_used
endef
else
- ifeq ($(strip $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY)),"")
- define Kernel/Prepare/Default
+ define Kernel/Prepare/Default
git clone $(CONFIG_KERNEL_GIT_CLONE_URI) $(LINUX_DIR)
- endef
- else
- define Kernel/Prepare/Default
- git clone --reference $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY) $(CONFIG_KERNEL_GIT_CLONE_URI) $(LINUX_DIR)
- endef
- endif
+ endef
endif
else
define Kernel/Prepare/Default