summaryrefslogtreecommitdiffstats
path: root/include/kernel-defaults.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-04-26 17:53:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-04-26 17:53:56 +0000
commit34ffb526a27dc3f1bf16cd6cdebbfa08c40a6d7a (patch)
tree8868b74560909f5524164014dc7e890be4d6f65d /include/kernel-defaults.mk
parentd7b7b99d6e9195e0e563d14336628b533b0fcd29 (diff)
downloadmaster-31e0f0ae-34ffb526a27dc3f1bf16cd6cdebbfa08c40a6d7a.tar.gz
master-31e0f0ae-34ffb526a27dc3f1bf16cd6cdebbfa08c40a6d7a.tar.bz2
master-31e0f0ae-34ffb526a27dc3f1bf16cd6cdebbfa08c40a6d7a.zip
build: rework verbosity level selection
V=99 and V=1 are now deprecated in favor of a new verbosity class system, though the old flags are still supported. You can set the V variable on the command line (or OPENWRT_VERBOSE in the environment) to one or more of the following characters: - s: stdout+stderr (equal to the old V=99) - c: commands (for build systems that suppress commands by default, e.g. kbuild) - w: warnings/errors only (equal to the old V=1) SVN-Revision: 31484
Diffstat (limited to 'include/kernel-defaults.mk')
-rw-r--r--include/kernel-defaults.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 6864793a27..0c188502fc 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -9,7 +9,8 @@ KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
CROSS_COMPILE="$(KERNEL_CROSS)" \
ARCH="$(LINUX_KARCH)" \
KBUILD_HAVE_NLS=no \
- CONFIG_SHELL="$(BASH)"
+ CONFIG_SHELL="$(BASH)" \
+ $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1)
ifdef CONFIG_STRIP_KERNEL_EXPORTS
KERNEL_MAKEOPTS += \
@@ -22,10 +23,6 @@ ifneq (,$(KERNEL_CC))
KERNEL_MAKEOPTS += CC="$(KERNEL_CC)"
endif
-ifeq ($(KBUILD_VERBOSE),99)
- KERNEL_MAKEOPTS += V=1
-endif
-
export HOST_EXTRACFLAGS=-I$(STAGING_DIR_HOST)/include
# defined in quilt.mk