summaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commita9d683ca912b2c4837b2e65909c09ca01babe3df (patch)
tree6cbca6e13dd0bb18c9d9f1d4baa9a0ea7801b959 /include/kernel-build.mk
parent4a2e4920b1d909ca254853b0dce46af3123e8f74 (diff)
downloadmaster-31e0f0ae-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.gz
master-31e0f0ae-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.bz2
master-31e0f0ae-a9d683ca912b2c4837b2e65909c09ca01babe3df.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
SVN-Revision: 8694
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk144
1 files changed, 26 insertions, 118 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 69e602aded..65907600c9 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -1,60 +1,20 @@
-#
+#
# Copyright (C) 2006-2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-KERNEL_BUILD:=1
-
include $(INCLUDE_DIR)/host.mk
-include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/prereq.mk
-override MAKEFLAGS=
-
-GENERIC_LINUX_CONFIG:=$(GENERIC_PLATFORM_DIR)/config-$(shell [ -f "$(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER)" ] && echo "$(KERNEL_PATCHVER)" || echo template )
-LINUX_CONFIG_DIR ?= ./config$(shell [ -d "./config-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
-LINUX_CONFIG ?= $(LINUX_CONFIG_DIR)/default
-
-ifneq ($(DUMP),)
- TMP_CONFIG:=$(TMP_DIR)/.kconfig-$(BOARD)-$(KERNEL)
- $(TMP_CONFIG): $(GENERIC_LINUX_CONFIG) $(LINUX_CONFIG)
- $(SCRIPT_DIR)/config.pl + $^ > $@
- -include $(TMP_CONFIG)
- .SILENT: $(TMP_CONFIG)
+ifneq ($(DUMP),1)
+ override MAKEFLAGS=
endif
-ifneq ($(CONFIG_PCI),)
- FEATURES += pci
-endif
-ifneq ($(CONFIG_USB),)
- FEATURES += usb
-endif
-ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)
- FEATURES += pcmcia
-endif
-
-# remove duplicates
-FEATURES:=$(sort $(FEATURES))
-
-ifeq ($(DUMP),1)
- all: dumpinfo
-else
+ifneq ($(DUMP),1)
all: compile
endif
-ifneq (,$(findstring uml,$(BOARD)))
- LINUX_KARCH:=um
-else
- LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
- -e 's/mipsel/mips/' \
- -e 's/mipseb/mips/' \
- -e 's/powerpc/ppc/' \
- -e 's/sh[234]/sh/' \
- -e 's/armeb/arm/' \
- )
-endif
-
STAMP_PREPARED:=$(LINUX_DIR)/.prepared
STAMP_CONFIGURED:=$(LINUX_DIR)/.configured
include $(INCLUDE_DIR)/quilt.mk
@@ -90,106 +50,54 @@ define BuildKernel
$(STAMP_PREPARED): $(DL_DIR)/$(LINUX_SOURCE)
-rm -rf $(KERNEL_BUILD_DIR)
-mkdir -p $(KERNEL_BUILD_DIR)
- $(call Kernel/Prepare)
+ $(Kernel/Prepare)
touch $$@
$(STAMP_CONFIGURED): $(STAMP_PREPARED) $(LINUX_CONFIG) $(GENERIC_LINUX_CONFIG) $(TOPDIR)/.config
- $(call Kernel/Configure)
+ $(Kernel/Configure)
touch $$@
$(LINUX_DIR)/.modules: $(STAMP_CONFIGURED) $(LINUX_DIR)/.config FORCE
- $(call Kernel/CompileModules)
+ $(Kernel/CompileModules)
touch $$@
$(LINUX_DIR)/.image: $(STAMP_CONFIGURED) FORCE
- $(call Kernel/CompileImage)
+ $(Kernel/CompileImage)
touch $$@
mostlyclean: FORCE
- $(call Kernel/Clean)
-
- ifeq ($(DUMP),1)
- dumpinfo:
- @echo 'Target: $(BOARD)'
- @echo 'Target-Kernel: $(KERNEL)'
- @echo 'Target-Name: $(BOARDNAME) [$(KERNEL)]'
- @echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'
- @echo 'Target-Arch: $(ARCH)'
- @echo 'Target-Features: $(FEATURES)'
- @echo 'Linux-Version: $(LINUX_VERSION)'
- @echo 'Linux-Release: $(LINUX_RELEASE)'
- @echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'
- @echo 'Target-Description:'
- @getvar $(call shvar,Target/Description)
- @echo '@@'
- @echo 'Default-Packages: $(DEFAULT_PACKAGES)'
- ifneq ($(DUMPINFO),)
- @$(DUMPINFO)
- endif
- endif
+ $(Kernel/Clean)
define BuildKernel
endef
-endef
-
-define Profile/Default
- NAME:=
- PACKAGES:=
-endef
-
-confname=$(subst .,_,$(subst -,_,$(1)))
-define Profile
- $(eval $(call Profile/Default))
- $(eval $(call Profile/$(1)))
- $(eval $(call shexport,Profile/$(1)/Config))
- $(eval $(call shexport,Profile/$(1)/Description))
- DUMPINFO += \
- echo "Target-Profile: $(1)"; \
- echo "Target-Profile-Name: $(NAME)"; \
- echo "Target-Profile-Packages: $(PACKAGES)"; \
- if [ -f ./config/profile-$(1) ]; then \
- echo "Target-Profile-Kconfig: yes"; \
- fi; \
- echo "Target-Profile-Config: "; \
- getvar "$(call shvar,Profile/$(1)/Config)"; \
- echo "@@"; \
- echo "Target-Profile-Description:"; \
- getvar "$(call shvar,Profile/$(1)/Description)"; \
- echo "@@"; \
- echo;
- ifeq ($(CONFIG_LINUX_$(call confname,$(KERNEL)_$(1))),y)
- PROFILE=$(1)
- endif
-endef
-
-$(eval $(call shexport,Target/Description))
-download: $(DL_DIR)/$(LINUX_SOURCE)
-prepare: $(STAMP_CONFIGURED)
-compile: $(LINUX_DIR)/.modules
- $(MAKE) -C image compile
+ download: $(DL_DIR)/$(LINUX_SOURCE)
+ prepare: $(STAMP_CONFIGURED)
+ compile: $(LINUX_DIR)/.modules
+ $(MAKE) -C image compile TARGET_BUILD=
-oldconfig menuconfig: $(STAMP_PREPARED) FORCE
- $(call Kernel/Configure)
- $(SCRIPT_DIR)/config.pl '+' $(GENERIC_LINUX_CONFIG) $(LINUX_CONFIG) > $(LINUX_DIR)/.config
+ oldconfig menuconfig: $(STAMP_PREPARED) FORCE
+ $(Kernel/Configure)
+ $(LINUX_CONFCMD) > $(LINUX_DIR)/.config
$(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $@
- $(SCRIPT_DIR)/config.pl '>' $(GENERIC_LINUX_CONFIG) $(LINUX_DIR)/.config > $(LINUX_CONFIG)
+ $(SCRIPT_DIR)/kconfig.pl '>' $(GENERIC_LINUX_CONFIG) $(LINUX_DIR)/.config > $(LINUX_CONFIG)
-install: $(LINUX_DIR)/.image
- $(MAKE) -C image compile install
+ install: $(LINUX_DIR)/.image
+ TARGET_BUILD="" $(MAKE) -C image compile install
-clean: FORCE
- rm -f $(STAMP_DIR)/.linux-compile
+ clean: FORCE
rm -rf $(KERNEL_BUILD_DIR)
-rebuild: FORCE
+ rebuild: FORCE
@$(MAKE) mostlyclean
@if [ -f $(LINUX_KERNEL) ]; then \
$(MAKE) clean; \
fi
@$(MAKE) compile
-image-prereq:
- $(SUBMAKE) -s -C image prereq
+ image-prereq:
+ $(SUBMAKE) -s -C image prereq TARGET_BUILD=
-prereq: image-prereq
+ prereq: image-prereq
+
+endef