summaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-30 21:49:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-30 21:49:25 +0000
commit5fe020342032679a1b1a7ee84f6151a48ea00928 (patch)
tree8f02573c0a2ef1759b939da7c61631afdfde3005 /include/kernel-build.mk
parent6c4ee48f9239dda93d6a34d4b3908e19171ee6e8 (diff)
downloadmaster-31e0f0ae-5fe020342032679a1b1a7ee84f6151a48ea00928.tar.gz
master-31e0f0ae-5fe020342032679a1b1a7ee84f6151a48ea00928.tar.bz2
master-31e0f0ae-5fe020342032679a1b1a7ee84f6151a48ea00928.zip
merge the kernel config parts at dump time, so that overrides that disable certain features work
SVN-Revision: 7812
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 83d0d5e6eb..4088422088 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -15,8 +15,13 @@ GENERIC_LINUX_CONFIG:=$(GENERIC_PLATFORM_DIR)/config-$(shell [ -f "$(GENERIC_PLA
LINUX_CONFIG_DIR ?= ./config$(shell [ -d "./config-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
LINUX_CONFIG ?= $(LINUX_CONFIG_DIR)/default
--include $(GENERIC_LINUX_CONFIG)
--include $(LINUX_CONFIG)
+ifneq ($(DUMP),)
+ TMP_CONFIG:=$(TMP_DIR)/.kconfig-$(BOARD)-$(KERNEL)
+ $(TMP_CONFIG): $(GENERIC_LINUX_CONFIG) $(LINUX_CONFIG)
+ $(SCRIPT_DIR)/config.pl + $^ > $@
+ -include $(TMP_CONFIG)
+ .SILENT: $(TMP_CONFIG)
+endif
ifneq ($(CONFIG_ATM),)
FEATURES += atm