summaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-16 05:28:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-16 05:28:13 +0000
commit0806675217a4f11d9236ab08725e99b51aa4eecd (patch)
tree09e06d09930158d17fede703305ed20908b91680 /include/kernel-build.mk
parent56ac6f5bea8b0d13d762bf8c77c1facef69e8dba (diff)
downloadmaster-31e0f0ae-0806675217a4f11d9236ab08725e99b51aa4eecd.tar.gz
master-31e0f0ae-0806675217a4f11d9236ab08725e99b51aa4eecd.tar.bz2
master-31e0f0ae-0806675217a4f11d9236ab08725e99b51aa4eecd.zip
kernel: fix dependencies for .config, use selections from oldconfig when running menuconfig
SVN-Revision: 7997
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 4088422088..1df80d16f6 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -98,15 +98,15 @@ define BuildKernel
$(call Kernel/Prepare)
touch $$@
- $(STAMP_CONFIGURED): $(LINUX_DIR)/.prepared $(LINUX_CONFIG)
+ $(STAMP_CONFIGURED): $(STAMP_PREPARED) $(LINUX_CONFIG) $(GENERIC_LINUX_CONFIG)
$(call Kernel/Configure)
touch $$@
- $(LINUX_DIR)/.modules: $(LINUX_DIR)/.configured $(LINUX_DIR)/.config FORCE
+ $(LINUX_DIR)/.modules: $(STAMP_CONFIGURED) $(LINUX_DIR)/.config FORCE
$(call Kernel/CompileModules)
touch $$@
- $(LINUX_DIR)/.image: $(LINUX_DIR)/.configured FORCE
+ $(LINUX_DIR)/.image: $(STAMP_CONFIGURED) FORCE
$(call Kernel/CompileImage)
touch $$@
@@ -169,11 +169,11 @@ endef
$(eval $(call shexport,Target/Description))
download: $(DL_DIR)/$(LINUX_SOURCE)
-prepare: $(LINUX_DIR)/.configured
+prepare: $(STAMP_CONFIGURED)
compile: $(LINUX_DIR)/.modules
-menuconfig: $(LINUX_DIR)/.prepared FORCE
- $(call Kernel/Configure)
+menuconfig: $(STAMP_PREPARED) FORCE
$(SCRIPT_DIR)/config.pl '+' $(GENERIC_LINUX_CONFIG) $(LINUX_CONFIG) > $(LINUX_DIR)/.config
+ $(call Kernel/Configure)
$(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) menuconfig
$(SCRIPT_DIR)/config.pl '>' $(GENERIC_LINUX_CONFIG) $(LINUX_DIR)/.config > $(LINUX_CONFIG)