summaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-20 02:30:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-20 02:30:36 +0000
commit84a0696c1ee5378fef9ec79b8e69cc7c2f0fa8a7 (patch)
tree60c38a0bd993154db8d166416a4b2a96f972f5ba /include/kernel-build.mk
parentc606df6563b0969de226087bebae65ee361fb5e6 (diff)
downloadmaster-31e0f0ae-84a0696c1ee5378fef9ec79b8e69cc7c2f0fa8a7.tar.gz
master-31e0f0ae-84a0696c1ee5378fef9ec79b8e69cc7c2f0fa8a7.tar.bz2
master-31e0f0ae-84a0696c1ee5378fef9ec79b8e69cc7c2f0fa8a7.zip
add descriptions to the broadcom target profiles and export them to the target metadata (not presented in menuconfig yet)
SVN-Revision: 6137
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 6d9c9d978d..9a1e36328b 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -206,10 +206,15 @@ endef
define Profile
$(eval $(call Profile/Default))
$(eval $(call Profile/$(1)))
+ $(eval $(call shexport,Profile/$(1)/Description))
DUMPINFO += \
echo "Target-Profile: $(1)"; \
echo "Target-Profile-Name: $(NAME)"; \
- echo "Target-Profile-Packages: $(PACKAGES)";
+ echo "Target-Profile-Packages: $(PACKAGES)"; \
+ echo "Target-Profile-Description:"; \
+ getvar "$(call shvar,Profile/$(1)/Description)"; \
+ echo "@@"; \
+ echo;
endef
$(eval $(call shexport,Target/Description))