summaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-20 22:23:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-20 22:23:51 +0000
commit4a17097247411d8676dc707ed4acd9e4907fa51f (patch)
tree8042a76b64f031e769d06d53a1aa080daf578828 /include/kernel-build.mk
parent31caccbd14ce2ef5a94fddeba9ab408eda9758de (diff)
downloadmaster-31e0f0ae-4a17097247411d8676dc707ed4acd9e4907fa51f.tar.gz
master-31e0f0ae-4a17097247411d8676dc707ed4acd9e4907fa51f.tar.bz2
master-31e0f0ae-4a17097247411d8676dc707ed4acd9e4907fa51f.zip
replace another instance of a relative path to generic-2.* with an absolute one (for symlinked target directories)
SVN-Revision: 5885
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 03b4769f4b..061d604927 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -63,7 +63,7 @@ endif
define Kernel/Prepare/Default
bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
- [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches
+ [ -d $(GENERIC_PLATFORM_DIR)/patches ] && $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches
[ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
endef
define Kernel/Prepare