summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorSergey Sergeev <adron@yapic.net>2016-06-16 22:04:51 +0300
committerFelix Fietkau <nbd@nbd.name>2016-06-26 13:06:36 +0200
commite6b93303437cd63d5f30787d5140ced73400e587 (patch)
tree9c0753abf9e9db1f4ab5dd058aacba22a745ef5b /include/image.mk
parent3d58d7f053eae83b59baf5c8b8a58da78653f605 (diff)
downloadmaster-31e0f0ae-e6b93303437cd63d5f30787d5140ced73400e587.tar.gz
master-31e0f0ae-e6b93303437cd63d5f30787d5140ced73400e587.tar.bz2
master-31e0f0ae-e6b93303437cd63d5f30787d5140ced73400e587.zip
build: Adds the ability to disable personal initramfs build for target device
If KERNEL_INITRAMFS := in the target/linux/*/image/Makefile->Device/%NAME% section is set to '' then personal initramfs file for this target device will not be created. This var is similar to the Device/Build/kernel KERNEL_INSTALL := Signed-off-by: Sergey Sergeev <adron@yapic.net>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index c86d739fc9..a47d588488 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -351,7 +351,7 @@ endef
ifndef IB
define Device/Build/initramfs
$(call Device/Export,$(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE),$(1))
- $$(_TARGET): $(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE)
+ $$(_TARGET): $$(if $$(KERNEL_INITRAMFS),$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE))
$(KDIR)/$$(KERNEL_INITRAMFS_NAME):: image_prepare
$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE): $(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE)