summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-21 13:41:20 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-21 13:41:20 +0200
commit8265fdcc4dda2554d4f7774e53020136079639b2 (patch)
treec7eaa39f84f1be818b845debb618f9a8fbeaee70 /include/image.mk
parented90d50bc4cbbcf615f880c1799814ccf743de8c (diff)
downloadmaster-31e0f0ae-8265fdcc4dda2554d4f7774e53020136079639b2.tar.gz
master-31e0f0ae-8265fdcc4dda2554d4f7774e53020136079639b2.tar.bz2
master-31e0f0ae-8265fdcc4dda2554d4f7774e53020136079639b2.zip
imagebuilder: strip DEVICE_ prefix from profiles (FS#55)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 43c144ad34..47cb1a58a9 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -327,7 +327,7 @@ define Device/Export
endef
ifdef IB
- DEVICE_CHECK_PROFILE = $(filter $(1),$(PROFILE))
+ DEVICE_CHECK_PROFILE = $(filter $(1),DEVICE_$(PROFILE) $(PROFILE))
else
DEVICE_CHECK_PROFILE = $(CONFIG_TARGET_$(if $(CONFIG_TARGET_MULTI_PROFILE),DEVICE_)$(call target_conf,$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET)))_$(1))
endif