summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-27 13:03:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-27 13:03:19 +0000
commitf22b382485839dceeac400900e56b39d27222746 (patch)
tree83519cc8e1a524e339bd8bd0738a1297d9b22e26 /include/image.mk
parent2ef587a8fc61b4d6697f567e11023156946ffdf7 (diff)
downloadmaster-31e0f0ae-f22b382485839dceeac400900e56b39d27222746.tar.gz
master-31e0f0ae-f22b382485839dceeac400900e56b39d27222746.tar.bz2
master-31e0f0ae-f22b382485839dceeac400900e56b39d27222746.zip
image.mk: make ubinize.cfg optional
When using UbinizeImage with ubifs rootfs, ubinize.cfg is no longer needed. Yet, the absance of ubinize.cfg would make the build process abort with an error. Fix that by checking if ubinize.cfg is present and do no not call the "classic" ubinize image generation if it isn't. Signed-off-by: Daniel Golle <daniel@makrotopia.org> [missing new-line before UbinizeImage added itentionally] SVN-Revision: 43788
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index d6c8b7af87..7375bf563f 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -146,6 +146,7 @@ ifneq ($(CONFIG_NAND_SUPPORT),)
(cd "$(KDIR_TMP)"; $(TAR) cvf \
"$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(2)-sysupgrade.tar" sysupgrade-$(1))
endef
+
# $(1) board name
# $(2) ubinize-image options (e.g. --uboot-env and/or --kernel kernelimage)
# $(3) rootfstype (e.g. squashfs or ubifs)
@@ -193,10 +194,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(call Image/Build,ubifs)
ifneq ($($(PROFILE)_UBI_OPTS)$(UBI_OPTS),)
- $(call Image/mkfs/ubifs/generate,)
+ $(if $(wildcard ./ubinize.cfg),$(call Image/mkfs/ubifs/generate,))
$(if $(wildcard ./ubinize-overlay.cfg),$(call Image/mkfs/ubifs/generate,-overlay))
endif
- $(call Image/Build,ubi)
+ $(if $(wildcard ./ubinize.cfg),$(call Image/Build,ubi))
endef
endif