summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-14 19:00:14 +0000
committerJohn Crispin <john@openwrt.org>2015-04-14 19:00:14 +0000
commitcc9a392e4975dc25a0fab1c6f008ff03b025c426 (patch)
tree48ba8500f92a7eca5d832531f3bd1184a9241c5e /include/image.mk
parent0bd2710512e22039f4b7a20673dfbe90de82407c (diff)
downloadmaster-31e0f0ae-cc9a392e4975dc25a0fab1c6f008ff03b025c426.tar.gz
master-31e0f0ae-cc9a392e4975dc25a0fab1c6f008ff03b025c426.tar.bz2
master-31e0f0ae-cc9a392e4975dc25a0fab1c6f008ff03b025c426.zip
opkg: drop md5 in favour of sha256
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 45437
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 31689c7e6b..165bf72f78 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -258,8 +258,7 @@ endef
define Image/Checksum
( cd ${BIN_DIR} ; \
- $(FIND) -maxdepth 1 -type f \! -name 'md5sums' -printf "%P\n" | sort | xargs \
- md5sum --binary > md5sums \
+ $(FIND) -maxdepth 1 -type f \! -name 'md5sums' -printf "%P\n" | sort | xargs $1 > $2 \
)
endef
@@ -461,6 +460,7 @@ define BuildImage
$(call Image/Build,$(fs))
)
$(call Image/mkfs/ubifs)
- $(call Image/Checksum)
+ $(call Image/Checksum,md5sum --binary,md5sums)
+ $(call Image/Checksum,openssl dgst -sha256,sha256sums)
endef