summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-29 13:41:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-29 13:41:31 +0000
commitbf93fde164dfddc1193076a94ef150e046e9f35e (patch)
treed154decc1deac83ab5b9fa009e58a128a763a7e8 /include/image.mk
parentd1372992c4a3337be4983e2b75dea6b49216e6fe (diff)
downloadmaster-31e0f0ae-bf93fde164dfddc1193076a94ef150e046e9f35e.tar.gz
master-31e0f0ae-bf93fde164dfddc1193076a94ef150e046e9f35e.tar.bz2
master-31e0f0ae-bf93fde164dfddc1193076a94ef150e046e9f35e.zip
build: do not call initramfs build from within the image builder
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45837
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 051f0f7e53..36c6c63320 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -471,7 +471,7 @@ define BuildImage
kernel_prepare: mkfs_prepare
$(call Image/BuildKernel)
- $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(call Image/BuildKernel/Initramfs))
+ $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(if $(IB),,$(call Image/BuildKernel/Initramfs)))
$(call Image/InstallKernel)
$(foreach device,$(TARGET_DEVICES),$(call Device,$(device)))