summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-09-04 14:45:09 +0000
committerJonas Gorski <jogo@openwrt.org>2015-09-04 14:45:09 +0000
commitb958c12d2c646a787f1eb37a334c3492778535c3 (patch)
tree3e7bfe8ee202ecc0552c97ce7266895929514450 /include/image.mk
parent156a25b9c45a91dcd885affa799345e66a0f1319 (diff)
downloadmaster-31e0f0ae-b958c12d2c646a787f1eb37a334c3492778535c3.tar.gz
master-31e0f0ae-b958c12d2c646a787f1eb37a334c3492778535c3.tar.bz2
master-31e0f0ae-b958c12d2c646a787f1eb37a334c3492778535c3.zip
image: move netgear-image to top and rename to -dni
Use the same naming as netgear-chk. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46791
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 8ac3593eae..d9fa03e454 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -308,6 +308,15 @@ define Build/netgear-chk
mv $@.new $@
endef
+define Build/netgear-dni
+ $(STAGING_DIR_HOST)/bin/mkdniimg \
+ -B $(NETGEAR_BOARD_ID) -v OpenWrt.$(REVISION) \
+ $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
+ -r "$(1)" \
+ -i $@ -o $@.new
+ mv $@.new $@
+endef
+
define Build/fit
$(TOPDIR)/scripts/mkits.sh \
-D $(DEVICE_NAME) -o $@.its -k $@ \