summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-11 09:17:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-11 09:17:51 +0000
commit9c7a520ba8a8b22c8880d68bf4141766b0ddfb62 (patch)
treed36481a892b857dbb954750b6cc7d3d9c5d9402d /include/image.mk
parent49e16828610436e38893b661489db7c0779750f5 (diff)
downloadmaster-31e0f0ae-9c7a520ba8a8b22c8880d68bf4141766b0ddfb62.tar.gz
master-31e0f0ae-9c7a520ba8a8b22c8880d68bf4141766b0ddfb62.tar.bz2
master-31e0f0ae-9c7a520ba8a8b22c8880d68bf4141766b0ddfb62.zip
image: disable compile target within image builder
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45674
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index b8be838313..921d78d10d 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -359,7 +359,7 @@ endef
define Device/Check
_TARGET = $$(if $$(filter $(PROFILE),$$(PROFILES)),install,install-disabled)
- _COMPILE_TARGET = $$(if $(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES)),compile,compile-disabled)
+ _COMPILE_TARGET = $$(if $(if $(IB),,$(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES))),compile,compile-disabled)
endef
ifndef IB