summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-30 13:03:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-30 13:03:58 +0000
commit6d7dff85964899bcd7ba001e8aea610ce2dc032b (patch)
tree9e43947f128c61b308eff2002ae9370617e3b7ae /include/image.mk
parent2b925161d8315f04598aabe2f40d04ce11ab7630 (diff)
downloadmaster-31e0f0ae-6d7dff85964899bcd7ba001e8aea610ce2dc032b.tar.gz
master-31e0f0ae-6d7dff85964899bcd7ba001e8aea610ce2dc032b.tar.bz2
master-31e0f0ae-6d7dff85964899bcd7ba001e8aea610ce2dc032b.zip
image.mk: fix initramfs kernel build instructions leaking across device sections
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45156
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 0d388ec666..08b516d854 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -353,7 +353,7 @@ define Device/ExportVar
$(1) : $(2):=$$($(2))
endef
-Device/Export = $(foreach var,$(DEVICE_VARS) KERNEL,$(call Device/ExportVar,$(1),$(var)))
+Device/Export = $(foreach var,$(DEVICE_VARS) KERNEL KERNEL_INITRAMFS,$(call Device/ExportVar,$(1),$(var)))
define Device/Check
_TARGET = $$(if $$(filter $(PROFILE),$$(PROFILES)),install,install-disabled)