summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-02 16:09:15 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-02 16:09:15 +0000
commit6cd84c68386d614b4838346b8b16f0431bd07e3e (patch)
tree658bde36cb97d078f983ececc1bba6953fb84eeb /include/image.mk
parent423af6adca85911671066465f68402da4f933622 (diff)
downloadmaster-31e0f0ae-6cd84c68386d614b4838346b8b16f0431bd07e3e.tar.gz
master-31e0f0ae-6cd84c68386d614b4838346b8b16f0431bd07e3e.tar.bz2
master-31e0f0ae-6cd84c68386d614b4838346b8b16f0431bd07e3e.zip
Use find -exec instead of xargs
SVN-Revision: 6837
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 78e1a2fdc8..eb59ea651c 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -79,9 +79,9 @@ endif
define Image/mkfs/prepare/default
- find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
- find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
- find $(BUILD_DIR)/root -type d | xargs chmod 0755
+ find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' -exec chmod 0644 {} \;
+ find $(BUILD_DIR)/root -type f -perm +0100 -exec chmod 0755 {} \;
+ find $(BUILD_DIR)/root -type d -exec chmod 0755 {} \;
mkdir -p $(BUILD_DIR)/root/tmp
chmod 0777 $(BUILD_DIR)/root/tmp
endef