summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-02 01:23:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-02 01:23:36 +0000
commit68ca8e7818356c0dbf2e0400b177139a656791c0 (patch)
treee8147a0b512f9bf0e42a6ac3f1a693b09c7c1971 /include/image.mk
parenta256c81dd99148e289dc7a73c01b9108701ad9d3 (diff)
downloadmaster-31e0f0ae-68ca8e7818356c0dbf2e0400b177139a656791c0.tar.gz
master-31e0f0ae-68ca8e7818356c0dbf2e0400b177139a656791c0.tar.bz2
master-31e0f0ae-68ca8e7818356c0dbf2e0400b177139a656791c0.zip
make squashfs overlay support more generic and integrate it for x86-2.6
SVN-Revision: 6450
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk18
1 files changed, 16 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index ec0512f904..9c170af11b 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -17,6 +17,19 @@ JFFS2OPTS := --pad --big-endian --squash
SQUASHFS_OPTS := -be
endif
+define add_jffs2_mark
+ echo -ne '\xde\xad\xc0\xde' >> $(1)
+endef
+
+# pad to 64k and add jffs2 end-of-filesystem mark
+# do this twice to make sure that this works with 128k blocksize as well
+define prepare_generic_squashfs
+ dd if=$(1) of=$(KDIR)/tmpfile.1 bs=64k conv=sync
+ $(call add_jffs2_mark,$(KDIR)/tmpfile.1)
+ dd of=$(1) if=$(KDIR)/tmpfile.1 bs=64k conv=sync
+ $(call add_jffs2_mark,$(1))
+endef
+
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
ifeq ($(CONFIG_TARGET_ROOTFS_JFFS2),y)
define Image/mkfs/jffs2
@@ -25,9 +38,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
$(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $(KDIR)/root.jffs2-64k -d $(BUILD_DIR)/root
$(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $(KDIR)/root.jffs2-128k -d $(BUILD_DIR)/root
+
# add End-of-Filesystem markers
- echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-64k
- echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-128k
+ $(call add_jffs2_mark,$(KDIR)/root.jffs2-64k)
+ $(call add_jffs2_mark,$(KDIR)/root.jffs2-128k)
$(call Image/Build,jffs2-64k)
$(call Image/Build,jffs2-128k)