summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-08 04:06:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-08 04:06:29 +0000
commit65ce91ec4116f07bf03830169563d1d4ad0fc123 (patch)
tree3540901ca9e547f8fa547b44dc0e12b5b3b5e272 /include/image.mk
parentaae28d712063583e53d6cc10c973a5df54b7a61b (diff)
downloadmaster-31e0f0ae-65ce91ec4116f07bf03830169563d1d4ad0fc123.tar.gz
master-31e0f0ae-65ce91ec4116f07bf03830169563d1d4ad0fc123.tar.bz2
master-31e0f0ae-65ce91ec4116f07bf03830169563d1d4ad0fc123.zip
minor cleanup
SVN-Revision: 5718
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk16
1 files changed, 7 insertions, 9 deletions
diff --git a/include/image.mk b/include/image.mk
index 70677b9c2f..1c36327c61 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -75,10 +75,12 @@ define Image/mkfs/prepare
endef
define BuildImage
-compile:
+download:
+prepare:
+compile: compile-targets
$(call Build/Compile)
-install:
+install: compile install-targets
$(call Image/Prepare)
$(call Image/mkfs/prepare)
$(call Image/BuildKernel)
@@ -87,16 +89,12 @@ install:
$(call Image/mkfs/tgz)
$(call Image/mkfs/ext2)
-clean:
+clean: clean-targets
$(call Build/Clean)
-endef
compile-targets:
install-targets:
clean-targets:
+endef
+
-download:
-prepare:
-compile: compile-targets
-install: compile install-targets
-clean: clean-targets