summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-15 07:45:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-15 07:45:36 +0000
commit61a0b05dbf0d163f6659f68a65b2b6a2aa3dbb26 (patch)
tree714a5ee57f8ab4741ebc9e6e3ea6f429581ae699 /include/image.mk
parenta417bf9f433fb7486c05071a35f03c9a4a5ce23b (diff)
downloadmaster-31e0f0ae-61a0b05dbf0d163f6659f68a65b2b6a2aa3dbb26.tar.gz
master-31e0f0ae-61a0b05dbf0d163f6659f68a65b2b6a2aa3dbb26.tar.bz2
master-31e0f0ae-61a0b05dbf0d163f6659f68a65b2b6a2aa3dbb26.zip
image.mk: add Build step pad-to
pad-to can be used in a pipe to pad the image to a specific chunk-size. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 45980
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 287c679cfd..814e7dc5d1 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -304,6 +304,11 @@ define Build/append-rootfs
dd if=$(word 2,$^) $(if $(1),bs=$(1) conv=sync) >> $@
endef
+define Build/pad-to
+ dd if=$@ of=$@.new bs=$(1) conv=sync
+ mv $@.new $@
+endef
+
define Build/pad-rootfs
$(call prepare_generic_squashfs,$@ $(1))
endef