summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-14 15:10:47 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-14 15:10:47 +0000
commit4e81a1473e0c7bc8620babb32ae6dc6418f1b13d (patch)
tree3d27241e6191d1c1db530080c96a7efd4705cf3e /include/image.mk
parent960113fcfcc1c56d89c1df957ecf8d07ddecae08 (diff)
downloadmaster-31e0f0ae-4e81a1473e0c7bc8620babb32ae6dc6418f1b13d.tar.gz
master-31e0f0ae-4e81a1473e0c7bc8620babb32ae6dc6418f1b13d.tar.bz2
master-31e0f0ae-4e81a1473e0c7bc8620babb32ae6dc6418f1b13d.zip
brcm63xx: move gzip build command to include/image.mk
Allow other targets to make use of it. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46601
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 56c60d6087..73fc805bb5 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -323,6 +323,11 @@ define Build/lzma
@mv $@.new $@
endef
+define Build/gzip
+ gzip -9n -c $@ $(1) > $@.new
+ @mv $@.new $@
+endef
+
define Build/kernel-bin
rm -f $@
cp $^ $@