summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-11 16:33:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-11 16:33:26 +0000
commit4baec2468a88a08058a97406e48a5b1faf3d1fa4 (patch)
treebe954e8b71cee419044b640547bf81c1b2d864e4 /include/image.mk
parente6fb730daa347e6e4866166857ae7b23c0ad378b (diff)
downloadmaster-31e0f0ae-4baec2468a88a08058a97406e48a5b1faf3d1fa4.tar.gz
master-31e0f0ae-4baec2468a88a08058a97406e48a5b1faf3d1fa4.tar.bz2
master-31e0f0ae-4baec2468a88a08058a97406e48a5b1faf3d1fa4.zip
include/image.mk: make tar reproducible
several packages reported different file order between builds make binutils, kmod-sched reproducible Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 46859
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index cf6717cf19..c59222e415 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -245,7 +245,7 @@ define Image/mkfs/cpiogz
endef
define Image/mkfs/targz
- $(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE),-$(PROFILE))-rootfs.tar.gz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
+ $(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE),-$(PROFILE))-rootfs.tar.gz --numeric-owner --owner=0 --group=0 --sort=name -C $(TARGET_DIR)/ .
endef
E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024*1024)))