summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-11 09:17:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-11 09:17:39 +0000
commit49e16828610436e38893b661489db7c0779750f5 (patch)
tree720ced69c654e75da7a329dc1d5f822145bf19b7 /include/image.mk
parent6ceb1b03581eda64eb9285bdc7d23f109cfb1e4e (diff)
downloadmaster-31e0f0ae-49e16828610436e38893b661489db7c0779750f5.tar.gz
master-31e0f0ae-49e16828610436e38893b661489db7c0779750f5.tar.bz2
master-31e0f0ae-49e16828610436e38893b661489db7c0779750f5.zip
build: disable initramfs build within image builder
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45673
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 1b7fd2404a..b8be838313 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -362,6 +362,7 @@ define Device/Check
_COMPILE_TARGET = $$(if $(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES)),compile,compile-disabled)
endef
+ifndef IB
define Device/Build/initramfs
$$(_TARGET): $(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE)
@@ -373,6 +374,7 @@ define Device/Build/initramfs
@rm -f $$@
$$(call concat_cmd,$$(KERNEL_INITRAMFS))
endef
+endif
define Device/Build/check_size
@[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -gt "$$(stat -c%s $@)" ] || { \