summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-04-26 11:43:24 +0000
committerJohn Crispin <john@openwrt.org>2016-04-26 11:43:24 +0000
commit2d255ac8d90c3cfa21a29056bade0a6d70335536 (patch)
tree418ca201ccaffeef915f6cc989a4967ebb88c806 /include/image.mk
parent6ade87df0ad6981b458f7714a7c10a584e608d02 (diff)
downloadmaster-31e0f0ae-2d255ac8d90c3cfa21a29056bade0a6d70335536.tar.gz
master-31e0f0ae-2d255ac8d90c3cfa21a29056bade0a6d70335536.tar.bz2
master-31e0f0ae-2d255ac8d90c3cfa21a29056bade0a6d70335536.zip
include: add a no dict version of lzma to new image build code
Required to compress kernels in a brnboot compatible way. Signed-off-by: Mathias Kresin <openwrt@kresin.me> SVN-Revision: 49240
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 7c11aa1c13..bc383e6ba8 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -336,7 +336,11 @@ define Build/fit
endef
define Build/lzma
- $(STAGING_DIR_HOST)/bin/lzma e $@ -lc1 -lp2 -pb2 $(1) $@.new
+ $(call Build/lzma-no-dict,-lc1 -lp2 -pb2 $(1))
+endef
+
+define Build/lzma-no-dict
+ $(STAGING_DIR_HOST)/bin/lzma e $@ $(1) $@.new
@mv $@.new $@
endef