summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-10-08 18:53:19 +0000
committerJohn Crispin <john@openwrt.org>2007-10-08 18:53:19 +0000
commit215fa7eb8b055e580c30a9851fbcacdc5fef15a6 (patch)
treeefdafbe4938b49e93198f6371d2cff7ba65506c4 /include/image.mk
parent0f4363326335a3acf67d821e6f4e6958bd2c4cba (diff)
downloadmaster-31e0f0ae-215fa7eb8b055e580c30a9851fbcacdc5fef15a6.tar.gz
master-31e0f0ae-215fa7eb8b055e580c30a9851fbcacdc5fef15a6.tar.bz2
master-31e0f0ae-215fa7eb8b055e580c30a9851fbcacdc5fef15a6.zip
added generation of x86 livecds, from #2391
SVN-Revision: 9191
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 68ce0480d1..fea7d1ce6f 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -81,6 +81,12 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
endef
endif
+ifeq ($(CONFIG_TARGET_ROOTFS_ISO),y)
+ define Image/mkfs/iso
+ $(call Image/Build,iso)
+ endef
+endif
+
define Image/mkfs/prepare/default
find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
@@ -113,6 +119,7 @@ ifneq ($(IB),1)
$(call Image/mkfs/squashfs)
$(call Image/mkfs/tgz)
$(call Image/mkfs/ext2)
+ $(call Image/mkfs/iso)
else
install: compile install-targets
$(call Image/BuildKernel)
@@ -120,6 +127,7 @@ else
$(call Image/mkfs/squashfs)
$(call Image/mkfs/tgz)
$(call Image/mkfs/ext2)
+ $(call Image/mkfs/iso)
endif
ifneq ($(IB),1)