summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:48 +0000
commit150a1b18c54b046291017d791ba15a4a06536173 (patch)
tree7618ee074d9f539c63c709194fe3c41efdd769ca /include/image.mk
parentd69efa4e1538b3667a684c8520dfd8d11662b258 (diff)
downloadmaster-31e0f0ae-150a1b18c54b046291017d791ba15a4a06536173.tar.gz
master-31e0f0ae-150a1b18c54b046291017d791ba15a4a06536173.tar.bz2
master-31e0f0ae-150a1b18c54b046291017d791ba15a4a06536173.zip
images: use configured distribution name for output image names
We allow to configure the version distribution name; let's also use it for the final image filenames. Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com> SVN-Revision: 48082
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk28
1 files changed, 15 insertions, 13 deletions
diff --git a/include/image.mk b/include/image.mk
index 1522dd72c8..4ffad28bd6 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -18,7 +18,21 @@ KDIR=$(KERNEL_BUILD_DIR)
KDIR_TMP=$(KDIR)/tmp
DTS_DIR:=$(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/dts
-IMG_PREFIX:=openwrt-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
+define toupper
+$(shell echo $(1) | tr '[:lower:]' '[:upper:]')
+endef
+
+define tolower
+$(shell echo $(1) | tr '[:upper:]' '[:lower:]')
+endef
+
+define sanitize
+$(shell echo $(call tolower,$(1)) | sed 's/_/-/g')
+endef
+
+DIST_SANITIZED:=$(call sanitize,$(VERSION_DIST))
+
+IMG_PREFIX:=$(DIST_SANITIZED)-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
MKFS_DEVTABLE_OPT := -D $(INCLUDE_DIR)/device_table.txt
@@ -85,18 +99,6 @@ define add_jffs2_mark
echo -ne '\xde\xad\xc0\xde' >> $(1)
endef
-define toupper
-$(shell echo $(1) | tr '[:lower:]' '[:upper:]')
-endef
-
-define tolower
-$(shell echo $(1) | tr '[:upper:]' '[:lower:]')
-endef
-
-define sanitize
-$(shell echo $(call tolower,$(1)) | sed 's/_/-/g')
-endef
-
PROFILE_SANITIZED := $(call sanitize,$(PROFILE))
define split_args