summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-07 12:51:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-07 12:51:24 +0000
commit141793c96cb9fb39f8848961bf0738976d9805ad (patch)
tree64951f9dfa93d437e347d368434a8e71715aa851 /include/image.mk
parent0afee7182025d84c771c521281799b9e76f09962 (diff)
downloadmaster-31e0f0ae-141793c96cb9fb39f8848961bf0738976d9805ad.tar.gz
master-31e0f0ae-141793c96cb9fb39f8848961bf0738976d9805ad.tar.bz2
master-31e0f0ae-141793c96cb9fb39f8848961bf0738976d9805ad.zip
include/image.mk: introduce KERNEL_INITRAMFS_NAME variable
In case if we're interested in generation of non-binary images (for example if we want images to be valid .elfs - and that's what we want for ARC now) we have to instruct Device/Build/initramfs target to use input file with some extension (in case of ARC it will be essentially .elf). Otherwise default binary vmlinux-initramfs (without extension) is used and resulting images then are binaries instead of elfs. Now having KERNEL_INITRAMFS_NAME variable it's possible to substitute default $$(KERNEL_NAME)-initramfs with preferred option like $$(KERNEL_NAME)-initramfs.elf. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: John Crispin <blogic@openwrt.org> SVN-Revision: 47403
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 43980bc394..5cd0d2302b 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -432,6 +432,7 @@ define Device/Init
KERNEL_IMAGE = $$(KERNEL_PREFIX)$$(KERNEL_SUFFIX)
KERNEL_INITRAMFS_PREFIX = $$(IMAGE_PREFIX)-initramfs
KERNEL_INITRAMFS_IMAGE = $$(KERNEL_INITRAMFS_PREFIX)$$(KERNEL_SUFFIX)
+ KERNEL_INITRAMFS_NAME = $$(KERNEL_NAME)-initramfs
KERNEL_INSTALL :=
KERNEL_NAME := vmlinux
KERNEL_SIZE :=
@@ -458,11 +459,11 @@ define Device/Build/initramfs
$(call Device/Export,$(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE),$(1))
$$(_TARGET): $(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE)
- $(KDIR)/$$(KERNEL_NAME)-initramfs: image_prepare
+ $(KDIR)/$$(KERNEL_INITRAMFS_NAME): image_prepare
$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE): $(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE)
cp $$^ $$@
- $(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE): $(KDIR)/$$(KERNEL_NAME)-initramfs
+ $(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE): $(KDIR)/$$(KERNEL_INITRAMFS_NAME)
@rm -f $$@
$$(call concat_cmd,$$(KERNEL_INITRAMFS))
endef