summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-19 16:08:18 +0200
committerJohn Crispin <blogic@openwrt.org>2016-04-19 16:08:18 +0200
commit1191eeff8ec86850a5a952987816823359f37793 (patch)
tree281be1db57007e0a409230cdccf859ff87640ad6 /include/image.mk
parent528ffec3cd6f49b4a98c8fce3d9b5dfb7f30e459 (diff)
downloadmaster-31e0f0ae-1191eeff8ec86850a5a952987816823359f37793.tar.gz
master-31e0f0ae-1191eeff8ec86850a5a952987816823359f37793.tar.bz2
master-31e0f0ae-1191eeff8ec86850a5a952987816823359f37793.zip
include: bin/ dir was not created
explicitly create the bin dir Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index a868afc0d6..9e342e0a42 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -574,11 +574,11 @@ define BuildImage
$(call Build/Clean)
image_prepare: compile
- mkdir -p $(KDIR)/tmp
+ mkdir -p $(BIN_DIR) $(KDIR)/tmp
$(call Image/Prepare)
else
image_prepare:
- mkdir -p $(KDIR)/tmp
+ mkdir -p $(BIN_DIR) $(KDIR)/tmp
endif
mkfs_prepare: image_prepare