summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-06-01 18:00:35 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-06-01 18:00:35 +0000
commit0d19e8da7fa2c3d7bf9991154f9b40431a5f5f63 (patch)
treeb4b8548169af2d433d2ec866a4b9d4b39e7c0c65 /include/image.mk
parent9c6945d7a15b19a0bd4b92ee5db3e2d6d7527365 (diff)
downloadmaster-31e0f0ae-0d19e8da7fa2c3d7bf9991154f9b40431a5f5f63.tar.gz
master-31e0f0ae-0d19e8da7fa2c3d7bf9991154f9b40431a5f5f63.tar.bz2
master-31e0f0ae-0d19e8da7fa2c3d7bf9991154f9b40431a5f5f63.zip
include: image.mk: ensure that $(KDIR)/tmp exists in the IB case as well
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45870
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 36c6c63320..020418d54d 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -464,6 +464,9 @@ define BuildImage
image_prepare: compile
mkdir -p $(KDIR)/tmp
$(call Image/Prepare)
+ else
+ image_prepare:
+ mkdir -p $(KDIR)/tmp
endif
mkfs_prepare: image_prepare