summaryrefslogtreecommitdiffstats
path: root/include/image-legacy.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-09-26 15:25:37 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-09-26 17:57:56 +0200
commita16a8814ead80984ce4ef7bed756434119b3aafa (patch)
tree8c0f95376ab484d1734d2915860c08ed6f713fcf /include/image-legacy.mk
parent6c1542787d135de358710254e71fe926f8676954 (diff)
downloadmaster-31e0f0ae-a16a8814ead80984ce4ef7bed756434119b3aafa.tar.gz
master-31e0f0ae-a16a8814ead80984ce4ef7bed756434119b3aafa.tar.bz2
master-31e0f0ae-a16a8814ead80984ce4ef7bed756434119b3aafa.zip
image: don't modify file permissions before rootfs generation
Modifying the file permissions can be harmful, as it would make files world-readable even if they weren't in the ipk packages. The Image/mkfs/prepare step is removed completely, as it is redundant now (/tmp and /overlay are already provided by base-files with the correct permissions). It has been verified that this change does not affect any permissions of files in the default package set except /etc/ppp/chap-secrets, which was world-readable before. All packages not in the default set are more likely to be installed via opkg than being part of a base image and thus were usually not affected by the permission modification anyways. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/image-legacy.mk')
-rw-r--r--include/image-legacy.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/include/image-legacy.mk b/include/image-legacy.mk
index 9960caba0c..edbee4c831 100644
--- a/include/image-legacy.mk
+++ b/include/image-legacy.mk
@@ -41,7 +41,7 @@ define LegacyDevice/Check
_TARGET := $$(if $$(_PROFILE_SET),legacy-images,install-disabled)
$$(if $$(_PROFILE_SET),install: legacy-images-make)
ifndef IB
- $$(if $$(_PROFILE_SET),mkfs_prepare: legacy-images-prepare-make)
+ $$(if $$(_PROFILE_SET),kernel_prepare: legacy-images-prepare-make)
endif
endef
@@ -90,5 +90,3 @@ define LegacyDevice
$(call LegacyDevice/$(if $(DUMP),Dump,Build),$(1))
endef
-
-