summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorBen Whitten <ben.whitten@lairdtech.com>2016-06-17 15:00:17 +0100
committerJohn Crispin <john@phrozen.org>2016-06-22 19:32:06 +0200
commitb7baaaf782f40bf6a1d017a1f41480b6229a12c9 (patch)
tree9b6969fd16d1ca63c61cdbfbe75a5bfeb1d25127 /include/image-commands.mk
parent7385f754b1a1562869ddf6a561f70623d626ed6b (diff)
downloadmaster-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.tar.gz
master-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.tar.bz2
master-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.zip
kernel: Move append-dtb to common image-commands
This build step is used by various targets, move it to a common section. Signed-off-by: Ben Whitten <ben.whitten@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index e156eb6004..e8549d46f6 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -38,6 +38,11 @@ define Build/tplink-safeloader
$(if $(findstring sysupgrade,$(word 1,$(1))),-S) && mv $@.new $@ || rm -f $@
endef
+define Build/append-dtb
+ $(if $(DEVICE_DTS_DIR),$(call Image/BuildDTB,$(DEVICE_DTS_DIR)/$(DEVICE_DTS).dts,$(DTS_DIR)/$(DEVICE_DTS).dtb))
+ cat $(DTS_DIR)/$(DEVICE_DTS).dtb >> $@
+endef
+
define Build/fit
$(TOPDIR)/scripts/mkits.sh \
-D $(DEVICE_NAME) -o $@.its -k $@ \